пятница, 31 июля 2009 г.

С Днём сисадмина!!!

Любите, девушки, админов,
Любите, девушки, скорей!
Админ - не глупая скотина,
Админ - не овощ-сельдерей.
Админ вам подмигнет тихонько,
Админ протянет проводок -
По проводам легко и звонко
Уже бежит любовный ток.
У монитора бутерброды
Лежат надкусанной горой…
Для благоденствия народа
Админ готов на все. Порой.
Порою взглянет он игриво
И комплимент начнет плести -
А значит, пару литров пива
Ему должны вы принести.
Откушав пару литров пива,
Админ приляжет на кровать,
Где вы устроились красиво,
И тут же закричит: «Е...ть!»
Вы приготовитесь смущенно
Раздвинуть ноги для него,
Но он их сдвинет возмущенно:
«Е...ть» не значит ничего.
И обижаться бесполезно,
И жизнь рассыпалась в куски.
Забита комната железом,
Везде валяются носки…
Как жить с титаном Возрожденья?
Тихонько в тряпочку сопи.
Ты вся дрожишь от возбужденья,
А он - про TCP/IP.
И ты останешься, бедняжка,
В стране нестиранных носков.
В углу лежат ботинки, фляжка…
Да, нрав админовский суров.
Ты встреть его, проста, красива,
Одета, скажем, в неглиже.
И пусть на кухне будет пиво,
И чтоб холодное уже.
Любите, девушки, админов,
Душа админа так тонка.
Админ - не сволочь, не скотина,
Админу хочется пивка! ©
С Днём сисадмина!!!!

четверг, 16 июля 2009 г.

Установка Mod_Layout на сервер (cpanel, др.)

Mod_Layout - является модулем апача, для вставки страниц в шапку и в "подвал" страницы :) тобишь в низ ) В основном используется для принудительной вставки рекламы в страницы :)

Замечание:
Если Вы используете апач версии 1.3, нужно использовать mod_layout-3.1
Если Вы используете апач версии 2, нужно использовать mod_layout-4.1
Если Вы используете апач версии 2.2, нужно использовать mod_layout-5.1
Ман сделан на примере апач 2.2


Итак, как установить mod_layout на сервер? Смотрим ниже :)

Идем в /tmp:
cd /tmp

качаем mod_layout:
wget http://download.tangent.org/mod_layout-5.1.tar.gz

[ad#ad-5]

Распакуем:
tar xvfz mod_layout-5.1.tar.gz

Идем в mod_layout-5.1
cd mod_layout-5.1

Правим Makefile:
vi Makefile

Убеждаемся что APXS путь правильный. Например для спанели:

Найти:

# the used tools
APXS=apxs
APACHECTL=apachectl
CC=`apxs -q CC`
INC=-I`apxs -q INCLUDEDIR` `$(APXS) -q CFLAGS` #-DLAYOUT_FILEOWNER_NAME
LD_SHLIB=`apxs -q LDFLAGS_SHLIB`


Заменить на:

# the used tools
APXS=/usr/local/apache/bin/apxs
APACHECTL=apachectl
CC=`/usr/local/apache/bin/apxs -q CC`
INC=-I`/usr/local/apache/bin/apxs -q INCLUDEDIR` `$(APXS) -q CFLAGS` #-DLAYOUT_FILEOWNER_NAME
LD_SHLIB=`/usr/local/apache/bin/apxs -q LDFLAGS_SHLIB`


Сохраняемся (Makefile):
:wq

Запускаем установку:
make install

[ad#ad-5]